Home Account & Billing Troubleshooting Payment Issues for VPN Users

Troubleshooting Payment Issues for VPN Users

Last updated on Jun 11, 2026

Issue:

You may encounter errors or failed transactions when attempting to make a payment while connected to VPN.


Cause:

Some VPNs route your internet traffic through regions that may block certain payment gateways.


Resolution:

Disconnect your VPN. Refresh the payment page. Retry the transaction.


Still having issues?

If the problem persists after disabling your VPN, please contact our support team with a screenshot of the error message and details of your attempted payment.